Back to overview
Degraded

PayPal Payments Failing

Dec 06 at 07:30pm GMT
Affected services
Billing Portal

Resolved
Dec 07 at 09:13am GMT

This issue appears to have been resolved. We are now seeing payments go through as normal.

Created
Dec 06 at 07:30pm GMT

We are aware of an issue causing PayPal payments to fail for a number of customers. Please pay using Credit/Debit Card, or contact support to arrange alternate payment during this time.