Back to overview
Downtime

Major Service Interruption

Apr 17 at 10:40am BST
Affected services
Penne
Nero

Resolved
Apr 17 at 11:56pm BST

The issue has now been resolved. All VPS services should be back online.

We sincerely apologise for the long period of downtime. Our team is working on finding the cause of the fault to prevent this issue reoccurring.

Updated
Apr 17 at 04:10pm BST

Work is still ongoing to restore affected VPS services. While we’ve made progress in replacing the faulty hardware and beginning recovery procedures, services are not yet fully restored.

We’re continuing to work as quickly as possible, but at this stage, we do not have a reliable ETA. We understand how disruptive this is and deeply apologise for the extended downtime. Further updates will be provided as soon as we have more information.

Updated
Apr 17 at 12:03pm BST

We have identified a severe hardware fault and are currently in the process of installing a replacement. At this time, we estimate that services will be back online within approximately 2 hours.

We sincerely apologise for the inconvenience and appreciate your patience while we work to resolve the issue.

Created
Apr 17 at 10:40am BST

We are aware of a major outage affecting a large number of our VPS services. We are investigating the issue as a matter or urgency, and will advise when we have an estimated time of resolution.

Dedicated servers are not affected at this time.